Team manage to resolve the issue! Changes were applied to the Back Office credit settlement so that it can be accessed with new URL!
We apologize for any inconvenience this service disruption may have caused. If you have any related issues, please contact us at 877-270-3475, email us at: customercare@ncrsilver.com or chat via Back Office.
Posted Jul 07, 2025 - 11:41 EDT
Identified
IImportant Update: We are currently making changes to our systems to better serve you. Please note that the login page has been updated. You can now access your account at https://merchant.roamdata.com/home_login. Thank you for your understanding.
We apologize for any inconvenience this service disruption may have caused. If you have any related issues, please contact us at 877-270-3475, email us at: customercare@ncrsilver.com or chat via Back Office.
Posted Jul 03, 2025 - 16:48 EDT
Investigating
We have been made aware of issues with accessing the Settlement page for merchants using the Ingenico platform. We are engaging with relevant parties to resolve. More updates to come.
We apologize for any inconvenience this service disruption may have caused. If you have any related issues, please contact us at 877-270-3475, email us at: customercare@ncrsilver.com or chat via Back Office.