POS freezing on authorizing payment screen.

Incident Report for NCRV Aloha Cloud

Resolved

We appreciate your patience while this incident was resolved. At this time we are seeing no processing issues with our vendor.

Please contact support should you experience any problems.

Thank you,
NCR Voyix
Posted Nov 15, 2025 - 10:37 EST

Monitoring

Credit card transactions are now processing successfully.

We will continue to monitor the situation closely, work with our vendor as needed, and address any issues promptly to ensure a smooth experience.

Thank you for your patience and understanding. If you encounter any related issues, please contact us at 877-270-3475.
Posted Nov 14, 2025 - 23:40 EST

Identified

This incident is only affecting a subset of clients.

The issue has been identified and we are working with our vendor to get resolution.

We apologize for any inconvenience and are working to restore full functionality.
Posted Nov 14, 2025 - 19:30 EST

Investigating

We are aware of an issue with our POS getting frozen when attempting to complete a CC transaction.
We are working to resolve this issue as quickly as possible.

We apologize for any inconvenience this service disruption may have caused. If you experience any related issues, please contact us at 877-270-3475.
Posted Nov 14, 2025 - 14:24 EST
This incident affected: Aloha Cloud by NCR Voyix, Silver Essentials Application by NCR Voyix, and Payments by NCR Voyix.